Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive
 

Debian packages

Cannot upgrade or remove a very old package?

Use the commands:
cd /var/cache/apt/archives     #to enter the directory with all deb archives

dpkg -D777 -r ARCHIVENAME  #to remove a package, with debug information

dpkg -D777 -i ARCHIVENAME-version-arch.deb  #to install it

With these commands you can know exactly where is the problem. Often, the info file for the old archive does not longer exist, so you have to edit the script file (for example /var/lib/dpkg/info/coreutils.prerm ) adding || true to bypass the error (for example install-info --remove INFOFILE || true )

Postfix + Amavis + Spamassassin + Dovecot

Is postfix very slow to process a huge mail queue?

  • Check that virus scanning is not too slow. If it's slow, don't use clamscan (very slow) but prefer clamdscan (clamav-daemon): it requires a lots of memory but it's much more faster than clamscan!
  • You can also increase max_servers value on /usr/sbin/amavisd-new to get more than 2 processes for mail scanning (then, increase local smptd on port 10025 or similar, in /etc/postfix/main.cf)

 

 

Pin It